IVR Installation & Upgrade

Requirements

Important

Please contact support contact@wisper.io to get access to the IVR Editor components

Server Requirements

The IVR Editor component must be installed on a XiVO server.

Base installation

1. Docker compose Installation

These commands will install docker compose on the host.

# Download docker compose
TAG_OR_BRANCH=2021.15
cd /etc/docker/xivo
wget https://gitlab.com/xivo.solutions/ivr-editor/-/raw/${TAG_OR_BRANCH}/docker-xivo-ivr.override.yml

2. IVR Editor configuration

  1. Enable IVR in custom.env file
echo "IVR_INSTALLED=yes" >> /etc/docker/xivo/custom.env
  1. Finally pull the new images and restart the containers:
xivo-dcomp pull
xivo-dcomp up -d

Upgrade

Currently there is no automatic upgrade process. Here is the manual process that you need to follow on the XiVO host.

  1. Make a backup of the IVR Editor compose override file:
cp -aR /etc/docker/xivo/docker-xivo-ivr.override.yml /var/tmp/docker-xivo-ivr.override.yml
  1. Re-download the ivr override compose file
# Download docker compose
TAG_OR_BRANCH=2021.15
cd /etc/docker/xivo
wget https://gitlab.com/xivo.solutions/ivr-editor/-/raw/${TAG_OR_BRANCH}/docker-xivo-ivr.override.yml
  1. Finally pull the new images and restart the containers:
xivo-dcomp pull
xivo-dcomp up -d